Peppermint | Linux OS Community Forum
 
It is currently Mon Jun 18, 2018 6:58 pm

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 20 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: The Dark Mod
PostPosted: Thu Jan 30, 2014 12:50 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Weird .. I've never seen known REISUB to fail except in a kernel panic (usually symbolised by flashing keyboard lights).

Unless your system is COMPLETELY locked up .. try this to shutdown

hit Ctrl+Alt+F2 to switch to a console
log in
then run:
Code:
sudo shutdown -P now

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 

 Post subject: Re: The Dark Mod
PostPosted: Thu Jan 30, 2014 4:49 pm 
Offline
User avatar

Joined: Wed Jan 01, 2014 7:40 pm
Posts: 116
Location: Amsterdam
Hi PCNetSpec, that works fine. The UNIX commands would have been better. I even tried holding down Alt +Ctrl+End/Prt Scr then REISUB. I needed a pencil gripped between my teeth for this maneuver :D . Even that didn't do anything. It must be something to do with my oddball keyboard. Anyway, I still can't get the video to work in The Dark Mod. Their forum is next to useless. It appears that they experienced a spat of spambots at the end of last year, Their solution is to individually screen new registrations for approval. This means you have to wait an indeterminate amount of time before you can use the forums functions. I'm sure this works for them but its a bit draconian and a bloody nuisance to boot. If you are up for troubleshooting The Dark Mod video issue, I'm up for it :) !

_________________
Backup! Backup! Backup! If you're missing any of these, you ain't Backed Up!


Top
 Profile  
 
 Post subject: Re: The Dark Mod
PostPosted: Thu Feb 06, 2014 4:57 pm 
Offline
User avatar

Joined: Wed Jan 01, 2014 7:40 pm
Posts: 116
Location: Amsterdam
I finally received my, "The Dark Mod" forums approval. It only took 8 days :x . Anyway, now I can access the site. I thought I could find the solution to my graphics issue. I think it is an OpenGL issue. I have tried running The Dark Mod from the terminal with the command from the directory where The Dark Mod is installed to.
Code:
./thedarkmod.x86
The game opens but it still open with no graphical interface, just sound. I have to exit the programme with
Code:
Ctrl+Alt+F2
I then login and again run
Code:
./thedarkmod.x86
I get a whole bunch of stuff that culminates in this error,
Quote:
Syst-Error: Unable to initialize OpenGL
About to exit with code 0
Segmentation fault


If anyone can help me troubleshoot this error, I'll be most grateful. Many thanks.

_________________
Backup! Backup! Backup! If you're missing any of these, you ain't Backed Up!


Top
 Profile  
 
 Post subject: Re: The Dark Mod
PostPosted: Thu Feb 06, 2014 5:14 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Something tells me it won't run from the Ctrl+Alt+F2 console as it's a graphical application.

What happens if (from your desktop) you open a terminal (ctrl+Alt+T) and run:
Code:
cd /path/to/the/thedarkmod/directory

then
Code:
./thedarkmod.x86

?

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: The Dark Mod
PostPosted: Thu Feb 06, 2014 5:24 pm 
Offline
User avatar

Joined: Wed Jan 01, 2014 7:40 pm
Posts: 116
Location: Amsterdam
PCNetSpec wrote:
Something tells me it won't run from the Ctrl+Alt+F2 console as it's a graphical application.

What happens if (from your desktop) you open a terminal (ctrl+Alt+T) and run:
Code:
cd /path/to/the/thedarkmod/directory

then
Code:
./thedarkmod.x86

?


I've already tried that and it opens but with no graphics only sound.

_________________
Backup! Backup! Backup! If you're missing any of these, you ain't Backed Up!


Top
 Profile  
 
 Post subject: Re: The Dark Mod
PostPosted: Thu Feb 06, 2014 7:09 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
No text in the terminal ?

Which graphics drivers are you using .. what's the output from:
Code:
sudo lshw -C display

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: The Dark Mod
PostPosted: Thu Feb 06, 2014 7:31 pm 
Offline
User avatar

Joined: Wed Jan 01, 2014 7:40 pm
Posts: 116
Location: Amsterdam
Thanks for that. Here is the the requested output:
Code:
andy@andy-AMILO-Li3710 ~ $ sudo lshw -C display
[sudo] password for andy:
  *-display:0             
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:47 memory:f2800000-f2bfffff memory:d0000000-dfffffff ioport:1800(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f2100000-f21fffff
andy@andy-AMILO-Li3710 ~ $


I am running the 32bit version of Peppermint OS Four. Those drivers look very generic.

_________________
Backup! Backup! Backup! If you're missing any of these, you ain't Backed Up!


Top
 Profile  
 
 Post subject: Re: The Dark Mod
PostPosted: Thu Feb 06, 2014 8:37 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
OK seems you probably need S3TC texture compression enabled.

Run:
Code:
sudo apt-get install libtxc-dxtn-s2tc0 driconf

then go to
menu > Preferences > 3D Acceleration > Image Quality (tab)
and make sure "Enable S3TC texture compression even if software support is not available" is set to "Yes".

Now try the game.

Dunno if you'll need to log off/on before trying the game .. so if it doesn't immediately work.....

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: The Dark Mod
PostPosted: Fri Feb 07, 2014 2:53 am 
Offline
User avatar

Joined: Wed Jan 01, 2014 7:40 pm
Posts: 116
Location: Amsterdam
Good morning PCnetSpec, that did the trick. I now have graphics . The fact that the game locks up is another story. I'll see what their forums have to say about this problem though. I guess the game needs some fine tuning to individual machines. I'm sure I'm not unique. I'll update this thread with the progress as it may help others. Many thanks again and have a great weekend ;).

Yep, I can safely say that adjusting the game settings did the trick. It is all up and running. The initial loading of the modules takes a long time but after that everything seems plain sailing. So if anyone is interested, I'm able to say, The Dark Mod works nicely on this machine.

PS: I've just seen the weather forecast for Cornwall. I guess you're in for another wild one. Stay safe :) !!

_________________
Backup! Backup! Backup! If you're missing any of these, you ain't Backed Up!


Top
 Profile  
 
 Post subject: Re: The Dark Mod [SOLVED]
PostPosted: Fri Feb 07, 2014 8:09 am 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
To tell the truth I'm not sure your graphics card is up to the task .. but can't hurt to try.

Yeah nice and sunny this morning (first time in weeks it's not been raining) then the say bigger storms are on the way.

"Come to sunny Cornwall" they said, "sunniest part of mainland England" they said.... :roll:

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL