Peppermint | Linux OS Community Forum
 
It is currently Fri Dec 06, 2019 1:34 pm

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Default keyring when setting uo wireless drivers (solved)
PostPosted: Wed Jul 20, 2011 5:57 pm 
Offline

Joined: Tue Jan 11, 2011 7:37 pm
Posts: 28
I'm using an old IBM Thinkpad A21m and I have an Trendnet wireless adapter and I use ndiswrapper to get it working .I have the correct .inf file and everything. When I make the connection when originally configuring the interface a window pops up asking for a default keyring password . I need to know if there's a way I can make it remember the password so I don't have to type it in to get wireless working . Or if I reconfigure the connection to not have to enter a password. ?


Last edited by rob0917 on Thu Jul 21, 2011 1:46 pm, edited 1 time in total.

Top
 Profile  
 
 

 Post subject: Re: Default keyring when setting uo windows wireless drivers
PostPosted: Thu Jul 21, 2011 6:57 am 
Offline

Joined: Tue Jun 15, 2010 8:27 am
Posts: 30
When you get the pop up window, try leaving the password field blank. You should get a message about using unsafe storage, blah, blah, blah. Confirm using unsafe storage and you should be good to go.


Top
 Profile  
 
 Post subject: Re: Default keyring when setting uo windows wireless drivers
PostPosted: Thu Jul 21, 2011 1:44 pm 
Offline

Joined: Tue Jan 11, 2011 7:37 pm
Posts: 28
That did the trick ,thanks


Top
 Profile  
 
 Post subject: Re: Default keyring when setting uo wireless drivers (solved
PostPosted: Sun Oct 23, 2011 12:26 pm 
Offline

Joined: Fri Oct 21, 2011 4:33 pm
Posts: 19
any other ideas on how to solve this problem.

I was configuring gnome-do and the keyring app showed up asking for the creation of a default password. I did so and now every time I turn on the computer I have to enter the keyring password. I have tried setting keyring to auto log in on start-up but it still pops up every time asking for a password. I have also tried leaving the password field blank and hitting ok but that just prompts the app to reask for the password.


One other thing. How do you launch keyring? It isn't in menu and gnome-do doesn't find it.


Top
 Profile  
 
 Post subject: Re: Default keyring when setting uo wireless drivers (solved
PostPosted: Wed Mar 21, 2012 10:16 am 
Offline

Joined: Sun Feb 19, 2012 1:05 pm
Posts: 34
I have the same problem.

Does anyone know how to stop this annoying password request. Or do I have to reinstall to get rid of it.


Top
 Profile  
 
 Post subject: Re: Default keyring when setting uo wireless drivers (solved
PostPosted: Fri Apr 06, 2012 7:39 pm 
Offline

Joined: Mon Apr 02, 2012 1:21 pm
Posts: 17
Since you guys have already set your default keyring password you can change it with the keyring manager. It's a bit obtuse as it's called "seahorse", it's not installed by default. Fire up your preferred software manager tool and install it. An option called "Password And Encryptions" will now appear in the "Preferences" section of the peppermint menu. Open that up and you can use it to manage your key rings and reset the Default keyring password. (note i'm on Peppermint Two and it's called "seahorse", but in older archived posts it's referred to as "gnome-keyring-manager" so if your using Peppermint One or Ice try that)

-----------------------------------
Now A Security Warning
-----------------------------------
Using a blank password on your Keyring will mean that all the passwords that keyring stores are saved on your hard disk in Plain Text! Meaning if someone can get on your machine while it's logged in then it's really easy for a user of even moderate experience to steal your keyring files(containg all passwords), also the system will automatically give them access to anything protected by the keyring, the seahorse config app will even show them your passwords if they go into it!

I felt it was only ethical to make you guys aware of this. I'll leave the decision on your systems security to you. However may I suggest that if your going to run with this then at least remove the seahorse program once you've removed the default password and every things working fine (hopefully this minimises the risk of a novice getting lucky).

----------------
Better Idea
----------------
An alternative solution would be to use a different wifi manager such as wcid (this one doesn't work with the gnome keyring).

Let me know how you guys get on and if that help.

Good Luck :)


Top
 Profile  
 
 Post subject: Re: Default keyring when setting uo wireless drivers (solved
PostPosted: Sat Apr 07, 2012 3:45 pm 
Offline
User avatar

Joined: Wed Mar 07, 2012 5:30 pm
Posts: 167
Location: Atlanta
I had the pop-ups asking for my keyring password every time I logged on(I think I had it in Linux Mint 12 too). I didn't see what the issue was, as I always just hit cancel. It made no difference, and I could still sign right onto the network and internet.
Anyways, I switched to Wicd(for other reasons) and it got rid of the password requests and logs me onto the network automatically. I'm not worried about security, so it's working well for me. It also helped me to increase my download speeds and stability of peer connections when using Deluge.

_________________
freedom defined is freedom denied


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL