Peppermint | Linux OS Community Forum
 
It is currently Mon Dec 17, 2018 8:49 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Can't boot after install
PostPosted: Thu Feb 20, 2014 8:18 pm 
Offline

Joined: Thu Feb 20, 2014 8:02 pm
Posts: 5
Hi everyone!

I've just installed Peppermint, but I can't boot to it when I'm on BIOS screen.
Here's what I made:
-First, I created a partition for Peppermint on Windows
-Then, I boot Peppermint from my hard drive (I don't remember the name of the software I used for this)
-I used the installer which was one the desktop and successfully completed the installation
-And then I reboot my computer, and Peppermint was still only accessible through live version.

Any idea about how I could fix that?
Thanks in advance!


Top
 Profile  
 
 

 Post subject: Re: Can't boot after install
PostPosted: Thu Feb 20, 2014 8:25 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
When you boot normally, do you get the Windows bootloader ... or the GRUB bootloader ?

Can you boot to the LiveCD/LiveUSB, open a terminal (Ctrl+Alt+T) and post the output from these 2 commands:
Code:
sudo fdisk -l

and
Code:
sudo blkid

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Can't boot after install
PostPosted: Thu Feb 20, 2014 8:31 pm 
Offline

Joined: Thu Feb 20, 2014 8:02 pm
Posts: 5
Here's what I get:
Quote:
peppermint@peppermint ~ $ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xeda47ac2

Device Boot Start End Blocks Id System
/dev/sda1 2048 41945087 20971520 27 Hidden NTFS WinRE
/dev/sda2 * 41945088 42149887 102400 7 HPFS/NTFS/exFAT
/dev/sda3 42149888 874371071 416110592 7 HPFS/NTFS/exFAT
/dev/sda4 874373118 976771557 51199220 f W95 Ext'd (LBA)
Partition 4 does not start on physical sector boundary.
/dev/sda5 874373120 976771557 51199219 83 Linux


peppermint@peppermint ~ $ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/sda1: LABEL="PQSERVICE" UUID="90386E83386E67E4" TYPE="ntfs"
/dev/sda2: LABEL="SYSTEM RESERVED" UUID="4AC26EE5C26ED52B" TYPE="ntfs"
/dev/sda3: LABEL="Packard Bell" UUID="4A28702E28701B61" TYPE="ntfs"
/dev/sda5: UUID="5c683d6a-6cd7-4173-9318-27d06e2690eb" TYPE="ext3"


And I don't have the GRUB bootloader, only the Windows one.


Top
 Profile  
 
 Post subject: Re: Can't boot after install
PostPosted: Thu Feb 20, 2014 8:51 pm 
Offline

Joined: Thu Feb 20, 2014 8:02 pm
Posts: 5
Well, in fact I solved the problem.
GRUB wasn't installed, so I did it, and then it works perfectly.

Anyway, thanks for your help ^^


Top
 Profile  
 
 Post subject: Re: Can't boot after install
PostPosted: Thu Feb 20, 2014 9:23 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Glad you solved the bootloader problem :)

Can I ask a question .. you don't seem to have a swap partition .. can you boot to Peppermint, and post the output from:
Code:
free -m

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Can't boot after install
PostPosted: Fri Feb 21, 2014 1:45 am 
Offline

Joined: Thu Feb 20, 2014 8:02 pm
Posts: 5
Yeah, I don't have one.
Is there a way to fix this without reinstalling?

Quote:
xephyr@xephyr-EasyNote-LS11HR ~ $ free -m
total used free shared buffers cached
Mem: 3807 892 2915 0 90 490
-/+ buffers/cache: 311 3495
Swap: 0 0 0


Top
 Profile  
 
 Post subject: Re: Can't boot after install
PostPosted: Sat Feb 22, 2014 12:58 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Sure .. resize /dev/sda5 using Gparted .. create a new swap partition in the free space you've just created inside sda4 .. mount it through fstab .. enable swap with:
swapon /dev/sda(n)

Let me know if you need help.

But to tell the truth with 4GB of RAM you may not need a swap partition .. really depends on your usage pattern.

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Can't boot after install
PostPosted: Sat Feb 22, 2014 8:09 pm 
Offline

Joined: Thu Feb 20, 2014 8:02 pm
Posts: 5
Okay, thanks, I'll ask you if it deosn't work ^^


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL