Peppermint | Linux OS Community Forum
 
It is currently Tue Sep 17, 2019 11:04 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Lost access to grub after installation
PostPosted: Sun Jul 07, 2013 1:49 pm 
Offline

Joined: Sun Jul 07, 2013 1:40 pm
Posts: 3
Hi,

I am hoping someone would be able to help me. I have installed peppermint 4 but after restarting it, the grub menu didn't show up and now it boots straight into Windows. I went back into peppermint by using "Try out Peppermint" option from the boot USB. I've also run
Code:
sudo fdisk -l
and this is the output.

Quote:
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd9aacbf3

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 821247 409600 27 Hidden NTFS WinRE
/dev/sda2 821248 489330687 244254720 7 HPFS/NTFS/exFAT
/dev/sda3 489330688 976773119 243721216 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x99954f66

Device Boot Start End Blocks Id System
/dev/sdb1 2048 557340671 278669312 7 HPFS/NTFS/exFAT
/dev/sdb2 * 557340672 557828095 243712 83 Linux
/dev/sdb3 557830142 691828735 66999297 5 Extended
/dev/sdb5 557830144 567828479 4999168 83 Linux
/dev/sdb6 567830528 667828223 49998848 83 Linux
/dev/sdb7 667830272 691828735 11999232 82 Linux swap / Solaris

Disk /dev/sdc: 16.2 GB, 16231956480 bytes
140 heads, 32 sectors/track, 7076 cylinders, total 31703040 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdc1 * 32 31703039 15851504 c W95 FAT32 (LBA)


The /boot partition for peppermint was set at /dev/sdb

In what way can I enable grub now?


Top
 Profile  
 
 

 Post subject: Re: Lost access to grub after installation
PostPosted: Sun Jul 07, 2013 2:35 pm 
Offline

Joined: Fri Sep 17, 2010 1:01 am
Posts: 2363
Location: Ohio
Yeah, you installed GRUB to your flash drive, not to your main hard drive. This is an issue with the latest version of Ubiquity and flash drives.

That means you still have BCD (the windows bootloader) on your master boot record. This isn't necessarily a bad thing. It's not ideal, but you should be able to work around it without reinstalling Peppermint. Which version of Windows do you have? If it's Vista or newer, you can simply use EasyBCD to create a boot entry for Peppermint.

http://neosmart.net/EasyBCD/

The free version is all you need. If you have questions about configuring it, feel free to ask. I have a lot of experience using EasyBCD.


Top
 Profile  
 
 Post subject: Re: Lost access to grub after installation
PostPosted: Sun Jul 07, 2013 3:20 pm 
Offline

Joined: Sun Jul 07, 2013 1:40 pm
Posts: 3
Hi, tnx for your reply.

Yeah I am running windows 7, and I have EasyBCD installed. I don't have any experience with it so would you mind just giving me a couple of pointers on how to make a boot entry for Peppermint?


Top
 Profile  
 
 Post subject: Re: Lost access to grub after installation
PostPosted: Sun Jul 07, 2013 3:41 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
The instructions are here:
https://neosmart.net/wiki/display/EBCD/Linux

But you need to have installed GRUB to the bootsector of the partition that Peppermint is being installed on, NOT the MBR of the sdb (or sda).

How come you have 3 Linux partitions (and a swap partition) on sdb ?

have you set up separate /boot, /, and /home partitions ?

if so, do you know which is which.

The boot flag (on the second HDD) seems to be set to sdb2 .. what's on this partition ?

are there any other Linux installations present ?

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Lost access to grub after installation
PostPosted: Sun Jul 07, 2013 4:29 pm 
Offline

Joined: Fri Sep 17, 2010 1:01 am
Posts: 2363
Location: Ohio
Oh, sorry, my mistake. I looked at that wrong and thought /dev/sdb was a flash drive. It's not, it's a second hard drive. It looks like sda is a Windows drive and sdb is the Linux drive. That actually makes things easier. You just have to go into BIOS mode and set the second hard drive to boot first. I would say you could simply swap them physically, but Windows probably won't boot if you do that. :roll: Once you set your second hard drive to boot first, you *should* be able to load everything using GRUB.

Alternately, you *can* use BCD to boot the Linux partitions, even if you have GRUB on the second drive. You simply have to set up a boot entry using EasyBCD for GRUB2. (NOT GRUB Legacy!) That boot entry will automatically find and load GRUB, no matter where it is on your system. Though, if that doesn't work, you can simply do option one and set the second drive to boot first. If it will help, I can reboot my computer into Windows 7 and do some screen shots on how to use EasyBCD to create the bootloader entry.


Top
 Profile  
 
 Post subject: Re: Lost access to grub after installation
PostPosted: Sun Jul 07, 2013 4:38 pm 
Offline

Joined: Sun Jul 07, 2013 1:40 pm
Posts: 3
Tnx for the info, I have managed to set the boot up from BCD which then loads grub2 if needed and to load windows by default.


Top
 Profile  
 
 Post subject: Re: Lost access to grub after installation
PostPosted: Sun Jul 07, 2013 4:59 pm 
Offline

Joined: Fri Sep 17, 2010 1:01 am
Posts: 2363
Location: Ohio
Cool. If this is fixed to your satisfaction, please edit the first post and add this to the title line: (Solved)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL