Peppermint | Linux OS Community Forum

peppermint will not boot
Page 2 of 3

Author:  stork92 [ Mon Jan 21, 2013 6:33 pm ]
Post subject:  Re: peppermint will not boot

I think that guy bought a x201e with Windows installed and subsequently booted a USB stick.

This is similar to what I am trying to do.
When I tried to boot the USB stick I had first to hit <esc> to reach either the setup (no usb plugged in) or a menu i have to select from:

UEFI: [usb stick name]
[usb stick name]

The first option leads nowhere; the second give the few results i mentionned. Setup goes to setup.

(and to reach that menu I have to <esc> early in the boot process, which leads to the setup menu or gives the choice to boot from USB if any).

in the setup menu,
Legacy usb support is set to Enable
XHCI is set to auto

I tried change it to disable, and boot from usb, but got the same strange result ie the peppermint boot screen and 12.04 ubuntu login screen.

Author:  PCNetSpec [ Mon Jan 21, 2013 7:17 pm ]
Post subject:  Re: peppermint will not boot

According to this:

it says:-
In your BIOS, disable QuickBoot/FastBoot and Intel Smart Response Technology (SRT).

are either of these present and enabled ?

Author:  stork92 [ Tue Jan 22, 2013 8:09 am ]
Post subject:  Re: peppermint will not boot

Not that I could see.
I check 3 times so I believe it is a reasonnable "no"

SRT is for some sort of ssd acceleration i doubt it would be supported on this unexpensive board anyway (the laptop was <300€, though i am impressed by the amount of technology this represents for the price and 1,25kg, or less than 3 pounds)

For UEFI I went to read a bit in the page you mentionned.

They give an example to know if you boot uefi or legacy
As the menu i have is

UEFI: [usb stick name]
[usb stick name]

this really means the USB would be booted UEFI (line 1, breaks) or legacy (line 2, gives strange results)

what puzzles me is
1- ubuntu usb will boot, with 386 or x64
2- peppermint does not, so as Slitaz does not either

Could this be related to GPT, instead of UEFI "per se" ??

Author:  PCNetSpec [ Tue Jan 22, 2013 8:22 am ]
Post subject:  Re: peppermint will not boot

Does a 12.04 (which Peppermint 3 is based on) LiveUSB work .. or only a 12.10.

and just as importantly .. how would you know a 12.04 LiveUSB isn't doing the same thing (ie. booting the 12.04 recovery partition) ?

This is a weird problem .. that's for sure .. and I can find no reference to anything similar online, but Ill keep looking.

My guess is you're right and it's a GPT issue .. but then I'd expect a 12.04 LiveUSB to do the same thing.



When you boot a 12.04 or 12.10 64bit LiveUSB .. do you need to select UEFI boot, or Legacy .. or do both work ?

I *think* I may be onto something .. Peppermint 3 64bit doesn't appear to have the /efi/boot/bootx64.efi file or the /boot/grub/<extra efi stuff> that is found on the Ubuntu 12.04/12.10 and Lubuntu 12.04/12.10.

Can you check if you're able to boot a Lubuntu 12.04 64bit LiveUSB .. you can get the ISO image from here: ... -amd64.iso
Reason I ask - The Lubuntu efi stuff seems a simplified version of the Ubuntu efi stuff .. and Peppermint is really Lubuntu based.
(I'm guessing the Ubuntu version allows you to boot in UEFI or Legacy mode, and the Lubuntu version just allows you to boot in Legacy mode)

If that works, we can probably copy the /efi and /boot directories from the Lubuntu LiveUSB to a Peppermint 3 64bit LiveUSB (though the config files *may* need a bit of tweaking).

As (kind of) described here:

Author:  stork92 [ Tue Jan 22, 2013 6:08 pm ]
Post subject:  Re: peppermint will not boot

ubuntu 12.04 386 boots from the stick (it is a live session with no login screen and an icon on the deskset to install it)
same with 12.10 (talking from memory)

my guess was that is would be booting the recovery partition but that was silly, maybe.
What I was seeing was a Ubuntu 12.04 login screen, with no guest or christophe option shown (that is the default on the disk partition). I tried to login my own name and password and it failed.
What do I know, maybe it sort of booted peppermint before getting confused and getting some files from the disk partition, wheter it found it from the recovery partition or the the installed partition, I cannot tell. My earlier guess was based on the fact that it did not look like the installed partition, but really, it does not look like anyghting (and the trackpad does not work and i cannot connect to do basic checkings)

12.04 64bit LiveUSB boots normally ! and it boots both legacy and uefi....

I can live with Ubuntu 12.04, I just installed the lxde package and i can live with that.

But definitely, there is something wrong with booting ppmint (but as long as i am the only one with this problems and until there is an epidemy of similar problems, we can thing it is not too bad.

I'll be happy to continue testing if you have other ideas. Been using ppmint on my desktop since september after using other lxde distros, and love it. Would have been more confortable with the same environment on my laptop :(

Author:  PCNetSpec [ Tue Jan 22, 2013 7:10 pm ]
Post subject:  Re: peppermint will not boot

2 things I'd appreciate you trying -

a) boot the Peppermint 3 LiveUSB .. when you get to the login screen, try:-

Username = peppermint
Password = <leave it blank>

b) I'd really like to know if Lubuntu 12.04 64bit works properly .. so we can try the EFI shell files on a Peppermint 3 64bit LiveUSB .. Lubuntu, NOT Ubuntu, it's linked in my last posting.

Author:  stork92 [ Wed Jan 23, 2013 6:35 pm ]
Post subject:  Re: peppermint will not boot

Sorry i wasnt clear in my previous post.

LUBUNTU 12.04 64bit LiveUSB boots normally ! and it boots both legacy and uefi.... (I tried both)

I tried againt the peppermint x64

No user peppermint (invalid passwd please try again)

When I try the user ubuntu however, with no passwd, something happens: the screen goes back to some console type and some messages show eg "starting bluetooth, checking battery level....stopping bluetoth"
maybe 6 to 10 messages of this kind, nothing that i can tell exactly cause it really is like a flashing screen before it goes back to the ubuntu login screen.

Also i paid attention at this time that during boot the usb is barely flashing at all while the disk is busy, so there is no doubt it is booting from the disk (or more precisely, loading something from the disk)

That would also be coherent with the x386 version jumping to a kernel panic (i remember your exponation on that, like some x386 code failing at loading x386 kernel, since it find x64 instead, on the disk).

I will investigate more, if you tell me how to do it. For me I am stuck.

(by the way in the meantime i installed lxde on ubuntu, that would make me happy for a while, except, there are no icons in the menu -next to the text-, which makes it a little slow to use.... any hint on how to activate them ? tx)

Author:  PCNetSpec [ Wed Jan 23, 2013 8:00 pm ]
Post subject:  Re: peppermint will not boot

OK, try this ..

Copy the directories called:-


from the root of the Lubuntu 12.04 64bit LiveUSB

to a Peppermint 3 64bit LiveUSB
(it should be safe to replace the "boot" directory on the Peppermint 3 64bit LiveCD with the one from Lubuntu 12.04 64bit)

Now try booting the Peppermint 3 64bit LiveUSB

Author:  stork92 [ Mon Jan 28, 2013 7:37 pm ]
Post subject:  Re: peppermint will not boot

Sorry for having been away
I hope to have enough time to do that tomorrow
I that boots as expected, what command should I issue from then on ?


Author:  PCNetSpec [ Tue Jan 29, 2013 6:33 am ]
Post subject:  Re: peppermint will not boot

You lost me there ?

I thought this was just about getting the Peppermint 3 USB stick to boot.

What command are you referring to, and what do you expect it to do ?

Page 2 of 3 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group