Peppermint | Linux OS Community Forum

Installation problems Peppermint Two
Page 1 of 1

Author:  Eric2 [ Sun Jun 12, 2011 7:24 pm ]
Post subject:  Installation problems Peppermint Two

One of the scenario's that seems to be occurring with booting form the liveCD on some systems results in ending up in an OpenBox session.
If you've read some of the documentation, you'll know that Peppermint is built with openbox underneath it.
If after trying to boot the liveCD you happen to end up with a black screen and a cursor, chances are good you're in an Openbox session.
Try right-clicking with your mouse and see if the default Openbox menu appears. If it does, user jmculv has posted how he got around it in the following thread

Author:  Eric2 [ Sun Jun 12, 2011 11:59 pm ]
Post subject:  Re: Installation problems Peppermint Two

Disclaimer.. YMMV I have no idea what hardware you're running or what affect or lack of these boot line commands will have for you.
So, please, do a little research on your hardware and if/why it may be applicable to you before you do take any of these suggestions.

Other issues with the liveCD not booting correctly, like ending up in a console session with a peppermint@peppermint prompt might have better results by editing the boot parameters before continuing on to boot.
The "greeting" screen for the liveCD tells you at the bottom of the screen to Hit Enter or Tab to edit
So press tab and the following command will appear.
/casper/vmlinuz noprompt cdrom-detect/try-usb = true file =/cdrom/preseed/ubuntu.seed boot = casper/initrd.lz quiet splash --

You can edit the line using the arrow keys for the cursor, just be sure to maintain the spacing.
I would suggest first removing quiet splash from the line, resulting in
/casper/vmlinuz noprompt cdrom-detect/try-usb = true file =/cdrom/preseed/ubuntu.seed boot = casper/initrd.lz  --
and then hitting Enter to continue the boot process and see what happens.
If it ends in a successful boot, Great!!

If it doesn't, then there are many different options for these parameters that can be tried.

This is all explained in great detail, and much better than I could, all over the web. Here's one such link
There's a brief list of some of the options you might want to try on the page.

If removing quiet splash didn't work, the next I would suggest is adding nomodeset to the bootline, resulting in
/casper/vmlinuz noprompt cdrom-detect/try-usb = true file =/cdrom/preseed/ubuntu.seed boot = casper/initrd.lz nomodeset quiet splash --

Some of the Acer, EEE users having trouble may want to give these a shot if nothing else works. I own neither and have not used either of the commands, so please do some googling and find out why you're doing it before you do
i915.modeset=0 xforcevesa

Again, this is just a suggestion that some of you having problems with the LiveCD booting properly may be able to overcome by using.
So, At your Own risk and all
Check the link, try some variations and please If you do have success with editing the boot parameters, come back and post what worked for you on what hardware by pasting the results of inxi -F for reference purposes

Author:  brand33 [ Sat Mar 30, 2013 2:28 am ]
Post subject:  Re: Installation problems Peppermint Two

NOt sure about it.............!!!

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group