Peppermint | Linux OS Community Forum
 
It is currently Sat Aug 24, 2019 7:22 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 12:06 am 
Offline

Joined: Wed Mar 05, 2014 11:45 pm
Posts: 6
Hi,

In preparing my laptop for sale I wanted to be sure no personal data would be recoverable and so used DBAN and unwittingly removed Windows. I figured I needed an OS to sell the laptop and found Peppermint OS 4. This is my first experience with Linux and it all seems fast and great, particularly on this machine, however, I'm not able to use it for Google Voice calling because the person on the other end can't hear anything from me.

I read up on PulseAudio as a fix and tried everything I've seen (using the Terminal to type all kinds of commands and install stuff...).

I've got PulseAudio and went into internal mic and changed the levels but the unfortunate receiver of my call only heard, "crushing aluminum" noises...

Any ideas on how I can fix this?

Thanks so much in advance!!


Top
 Profile  
 
 

 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 1:27 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
What's the make/model of laptop ?

and what's the output from:
Code:
sudo lshw -C multimedia

and
Code:
aplay -l

and
Code:
arecord -l

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 1:40 pm 
Offline

Joined: Wed Mar 05, 2014 11:45 pm
Posts: 6
Hi!

Thanks for such a quick reply!

It's a Lenovo U460 Ideapad, i3 dual core 2.5Ghz.

*-multimedia
description: Audio device
product: 5 Series/3400 Series Chipset High Definition Audio
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 05
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:44 memory:d6400000-d6403fff

and

aplay: invalid option -- '1'
Try `aplay --help' for more information.

and

arecord: invalid option -- '1'
Try `arecord --help' for more information.

Maybe I didn't type it in right??

Thanks so much!
Jason


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 1:59 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
those are both lower case L's not 1's ;)

can you also post the output from:
Code:
cat /proc/asound/card0/codec* | grep Codec


it's may be easier to copy commands from this forum and paste them into the terminal ;)

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 5:02 pm 
Offline

Joined: Wed Mar 05, 2014 11:45 pm
Posts: 6
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ALC259 Analog [ALC259 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0


**** List of CAPTURE Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ALC259 Analog [ALC259 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0


The last code you asked for I didn't enter the suffix so to speak because I am having a hard time figuring out that character between codec and grep and already tried cutting and pasting into the terminal and that's not working either.

Another thing that's delaying this is my laptop with Peppermint isn't connecting to the WiFi I'm now nearest to and it's only due to a friend's computer that I can transfer this text to her machine via USB and then submit via her WiFi connection at this location...

Thanks,
Jason


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 5:07 pm 
Offline

Joined: Wed Mar 05, 2014 11:45 pm
Posts: 6
Ok so I figured out in Terminal I cannot use hotkeys I'm familiar with but can use the Edit option up top.

Here's what it says when I typed: cat /proc/asound/card0/codec* | grep Codec

Realtek ALC259
Intel IbexPeak HDMI

If you have any thoughts on how to get my WiFi authentication to work that would be tops too!

Thanks for all the help on this!
Jason


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 5:39 pm 
Offline
User avatar

Joined: Wed Jan 01, 2014 7:40 pm
Posts: 116
Location: Amsterdam
Zaldar, how are you doing? Right click on the WiFi bar graph in the panel. Select your network from the list or from "More networks". You will be asked to enter your administrator password, (the one you selected when you installed the OS) - hit enter. You will then be presented with a window that you can enter your WiFi password or encryption key. Hit enter and you should connect. Good luck :) !

_________________
Backup! Backup! Backup! If you're missing any of these, you ain't Backed Up!


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 6:04 pm 
Offline

Joined: Wed Mar 05, 2014 11:45 pm
Posts: 6
Thanks! I entered the network key instead of my password so that was the issue. It's a lot of password entering!


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Thu Mar 06, 2014 6:21 pm 
Offline
User avatar

Joined: Wed Jan 01, 2014 7:40 pm
Posts: 116
Location: Amsterdam
You should only have set this once for every time you add a new network. Keeps it all nice and safe. :D !

_________________
Backup! Backup! Backup! If you're missing any of these, you ain't Backed Up!


Top
 Profile  
 
 Post subject: Re: Microphone not working Peppermint 4 OS
PostPosted: Fri Mar 07, 2014 10:20 am 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Try this...

Open a terminal and run:
Code:
sudo apt-get install pulseaudio pulseaudio-utils pavucontrol

and hit enter.
then run:
Code:
alsamixer

and hit enter.

The terminal will change to a mixer.

Hit F4 to change to the Capture devices.

Hit the right arrow key .. so Capture is light in red (at the bottom).

Hit the Q key till the left volume is at 75% .. the Z key will lower if you go too far.

Hit the C key till the right volume is at 0% .. the E key will raise it, but you want it on zero

Close the terminal

Now test your mic.

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL