Peppermint | Linux OS Community Forum
 
It is currently Tue Nov 12, 2019 5:08 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Alienware M17xR3 --No Sound
PostPosted: Tue Apr 24, 2012 3:34 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
pwnsauce wrote:
--[I opted to show you more than 5 lines to point out this..
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2


AFAIK, those lines are just there to stop some TV cards, Modems, and USB audio devices from becoming the first registered sound device.

Try them without the index=0 option .. if non of them work, we'll take it from there.

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 

 Post subject: Re: Alienware M17xR3 --No Sound
PostPosted: Tue Apr 24, 2012 5:38 pm 
Offline
User avatar

Joined: Tue Sep 27, 2011 12:15 am
Posts: 940
Location: Lake Gaston NC
pwnsauce
Sorry to have left you but I had to go to work. You've been kept plenty busy, though, I see.
Not to insult your intelligence but check alsamixer to make sure you have the right sound device selected.

regards
mac

_________________
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835
http://peppermintos.com/guide/
viewforum.php?f=5
viewforum.php?f=44


Top
 Profile  
 
 Post subject: Re: Alienware M17xR3 --No Sound
PostPosted: Wed Apr 25, 2012 1:58 am 
Offline

Joined: Mon Apr 23, 2012 8:48 pm
Posts: 16
Location: Hamilton, Ontario, Canada
I only have two choices for cards in Alsamixer..
HDA Intel PCH <-- This is the only thing in alsamixer I can modify
or
HDA Nvidia <-- S/PDIF

No worries, you're not insulting much =D

_________________
--[
lspci -vvnn(unedited)
inxi -F
]--


Top
 Profile  
 
 Post subject: Re: Alienware M17xR3 --No Sound
PostPosted: Wed Apr 25, 2012 10:26 am 
Offline
User avatar

Joined: Tue Sep 27, 2011 12:15 am
Posts: 940
Location: Lake Gaston NC
Sorry, pwnsauce, but I'm stumped. The responses you've received have offered pretty sound advice (pardon the pun) but still no sound. I'll look around a bit as time permits and post back as / if I find something useful. I believe it's something simple but overlooked. Meanwhile, keep the community posted on what you find......a solution, hopefully.

regards
mac

_________________
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835
http://peppermintos.com/guide/
viewforum.php?f=5
viewforum.php?f=44


Top
 Profile  
 
 Post subject: Re: Alienware M17xR3 --No Sound
PostPosted: Wed Apr 25, 2012 10:50 am 
Offline
User avatar

Joined: Mon Jan 30, 2012 5:10 pm
Posts: 131
I never saw if the pulseaudio was ever tried. I know that is what worked for me along with paman and some other pulseaudio parts and pieces, but maybe not for everyone.

_________________
Hang loose.


Top
 Profile  
 
 Post subject: Re: Alienware M17xR3 --No Sound
PostPosted: Fri Apr 27, 2012 7:57 am 
Offline

Joined: Mon Apr 23, 2012 8:48 pm
Posts: 16
Location: Hamilton, Ontario, Canada
So I solved my sound problem. Although, I kind of stumbled upon the solution. I'll post my settings momentarily

--[ /etc/modprobe.d/alsa-base.conf
Code:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel index=0 model=dell-m6-dmic



--[Be sure to check and make sure there are no other saved "/etc/modprobe.d/alsa-base".conf files...
I had found extra save files earlier and removed them. I'm not entirely sure if that's what fixed it, but it works now.. I would like to thank all of you guys for the prompt feedback.. You guys are awesome!

--[ If you see anything in this file that is incorrect, please let me know.. Thx!

_________________
--[
lspci -vvnn(unedited)
inxi -F
]--


Top
 Profile  
 
 Post subject: Re: Alienware M17xR3 --No Sound[SOLVED]
PostPosted: Fri Apr 27, 2012 9:08 am 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Though I haven't been through it with a fine toothed comb and compared it to a default alsa-base.conf .. at first glance it looks OK to me.

And according to the tried and tested formula .. if t aint broken, don't fix it :)

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Alienware M17xR3 --No Sound[SOLVED]
PostPosted: Fri Apr 27, 2012 10:46 am 
Offline
User avatar

Joined: Tue Sep 27, 2011 12:15 am
Posts: 940
Location: Lake Gaston NC
Outstanding, pwnsauce! Thanks for posting back with your solution. As for as your modprobe.d being correct / incorrect, like PCNetSpec said,
Quote:
.. if t aint broken, don't fix it


regards
mac

_________________
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835
http://peppermintos.com/guide/
viewforum.php?f=5
viewforum.php?f=44


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL