Peppermint | Linux OS Community Forum
https://peppermintos.net/

Possible Firefox 4 related issue with ebuddy? (closed)
https://peppermintos.net/viewtopic.php?f=51&t=1411
Page 2 of 2

Author:  PixelPlane [ Mon Aug 16, 2010 5:05 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

Been any luck reproducing the issue? :P

Author:  Rich_Roast [ Mon Aug 16, 2010 7:41 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

Sadly, plenty of luck.

It's definitely a bug against Prism but I'm not intelligent enough as to how either eBuddy works or what it relies on in the client to even begin thinking about a direct fix. I'll start researching this when it comes around in the cycle unless someone beats me to it. What puzzles me is that it works fine in Firefox... so in theory it should in the Prism. Although that itself suggests something in either the way Prism is configured, or the way in which it is stripped, is preventing eBuddy from working as expected.

If anybody wants to help then it might be helpful to test this on their own boxes. Working or not, if submitting a test please let us know which version of prism they're using, and out of interest what version of Firefox

Code:
prism --version

Code:
firefox --version


Thanks.

Author:  PixelPlane [ Tue Aug 17, 2010 12:44 am ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

Rich_Roast wrote:
Sadly, plenty of luck.

It's definitely a bug against Prism but I'm not intelligent enough as to how either eBuddy works or what it relies on in the client to even begin thinking about a direct fix. I'll start researching this when it comes around in the cycle unless someone beats me to it. What puzzles me is that it works fine in Firefox... so in theory it should in the Prism. Although that itself suggests something in either the way Prism is configured, or the way in which it is stripped, is preventing eBuddy from working as expected.

If anybody wants to help then it might be helpful to test this on their own boxes. Working or not, if submitting a test please let us know which version of prism they're using, and out of interest what version of Firefox

Code:
prism --version

Code:
firefox --version


Thanks.


Well I think I saw that the XULRunner version in this respin was SVN, which I don't think I recalled seeing in the previous respin. I'll be editing this post with my own output for those commands shortly, and I believe I have a friend with an older respin to recieve his input in due time. I just have to make contact with him.

Author:  Rich_Roast [ Tue Aug 17, 2010 1:19 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

Thanks for the research and the testing. If it's something that needs reporting up stream or fixing this is one of the best ways we can contribute back to Mozilla.

Author:  PixelPlane [ Wed Aug 18, 2010 2:24 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

Rich_Roast wrote:
Thanks for the research and the testing. If it's something that needs reporting up stream or fixing this is one of the best ways we can contribute back to Mozilla.


SORRY THAT TOOK SO LONG. Been distro hoping a bit, as I'm experimenting enlightenment. Debating if I should try shoving it onto Peppermint (e17 slightly unstable) or using PCLinuxOS e17, which is fast as heck, stable feeling, but the repo is kinda eeeeeeh... ANYWHO. On topic, as per earlier...

...the ebuddy issue seems to be related to a normal update and not firefox 4.0s inclusion at all, as an up-to-date older respin (the one my friend possessed) had the exact same issue with ebuddy. Both prism --version output was identicle with version 1.03b. Unsure if xulrunner's update from 1.9.2.3 to 1.9.2.8 is also responsible (a "force version" sans reboot seems to prove against this). NOTE: Forgot to add his version of firefox is 3.6.8 I believe.

Author:  Rich_Roast [ Wed Aug 18, 2010 2:45 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

Thanks for this. So we can rule out Firefox (which is to be expected as I believe the prism package is independent of Firefox); thanks also for checking with xulrunner (I wouldn't expect changing the version to require a reboot to have changes kick in either).

Which leaves prism itself, I guess. I'm drowning in "real life" waters right now but will check in again when things permit me. In the meantime further feedback more than welcome. It'd be nice to have the eBuddy prism working again.

Author:  Rich_Roast [ Sun Sep 05, 2010 2:07 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

Bug report.

Edit: I messed up before by posting the wrong link, sorry :oops: The bug remains unconfirmed upstream.

Author:  Rich_Roast [ Sat Oct 09, 2010 8:06 am ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

The bug report mentioned above is still open as unconfirmed and I tested this yesterday and it still appears broken. This is a bump. It is possible to vote for bugs on bugzilla.

Author:  Rich_Roast [ Mon Dec 27, 2010 1:39 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

I just tried again. I rarely give up entirely even if something goes on the backburner. Sadly, problem appears not to have fixed itself, although I couldn't test with a live recipient. PM me if you want to share an address and a time when we can test it properly.

Author:  MR4Y [ Mon Dec 27, 2010 5:48 pm ]
Post subject:  Re: Possible Firefox 4 related issue with ebuddy?

that happened to me when I fist tried ebuddy in One. Later, I didn't had this problem in both versions of ebuddy.

Page 2 of 2 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/