Peppermint | Linux OS Community Forum
It is currently Fri Jun 05, 2020 8:26 am

All times are UTC - 5 hours [ DST ]

Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: B43 problems? Look here first
PostPosted: Fri Oct 28, 2011 8:58 am 
User avatar

Joined: Thu May 20, 2010 8:56 am
Posts: 2132
Class: Broadcom 43 fix
Difficulty: Not too bad, since it should only require the installation of pre-compiled packages
Time: Depends on where you're sourcing the packages from
Desirability: Look here first if the Install Hardware Drivers application hasn't gotten your Broadcom wifi working

Thanks to masinick's thread which pointed out some updates to Jay's previous tutorial. The main message here is that there should be no need to compile any source code to get a Broadcom card working, so please refer to this slightly new set of instructions which just streamline Jay's instructions a little.

Most of the time, Broadcom users just need to run the Hardware Drivers application to install the Broadcom firmware and drivers. How they connect to the Internet to do that is dependent on users' personal situations, so is best left to them. Posting for suggestions on how to obtain the drivers without a wired or other connection to the Internet is perfectly fine -- do it in New Users or Networking boards, please.

The Hardware Drivers application is however sometimes known to fail. The current writer is not a Broadcom user (nor is he likely ever to be! ;-) ), but the following guidance comes from the aforementioned thread by Masinick, which in turn is supported by Debian's wiki and It is worthwhile referring to those links first and using them as a starting point if the following potted guide does not work straight away, before posting to the support forums.

Theoretically, then, there is but one step to follow should your Broadcom wifi not be working subsequent to running the hardware drivers utility:

apt install firmware-b43-installer

By way of explanation, firmware-b43-installer is a metapackage which installs all the bits and pieces required, and tries to configure your system to use them. Ideally that should be the only command you need.

However, depending entirely on the current state of a user's system it is possible that it does not run all of its steps correctly. If the wireless device is still not working it is worth running

sudo modprobe b43
sudo modprobe b43legacy
(not both!) to force the module to load. Check that the device has a valid interface:
-- what you're looking for here is something like
wlan0 IEEE 802.11abgn...
-- what you don't want to see is everything having 'no wireless extensions'. If that does happen then try the b43legacy driver if you haven't already with
sudo rmmod b43 && modprobe b43legacy
, and then see the note at the bottom of this tutorial.

Assuming that that step has worked
ifconfig wlan0 up
will raise the device and you should within a few moments see it appear on the network manager icon (you'll need to click it to get the menu up, natch).

That should be it. If for whatever reason you end up needing to manually
sudo modprobe b43
every time you boot (this shouldn't happen but just for the sake of completeness), add the single line
not both! to the end of the file at
-- you'll need to have root privileges to do this.


If things aren't working it might be worth checking compatibility of your device using the instructions given on You just need to copy and paste that command into a terminal window and cross reference the ID of the device using the table.

The installer package tells me that it supports the following chipsets:

   - BCM4306/3
  - BCM4311
  - BCM4312
  - BCM4318

There is a curveball in that it would appear that one bcm chipset supports low power, aka LP-PHY. I don't know if the regular installer works with this chipset or not but in any case here's the code for installing the package specific to that device:

apt install firmware-b43-lpphy-installer

It supports this chipset:

- BCM4312 (with Low-Power aka LP-PHY)

At a guess it is best not to modprobe both at the same time, and while I wouldn't envision any problems with having both simultaneously installed, I wouldn't recommend it.

If, through cross referencing with the table given on you discover that your chipset does not appear to be supported by the linux modules and firmware cutter, it is probably time to look into ndiswrapper. Look this up, and scroll down until you see shades of yellow.



Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL