Peppermint | Linux OS Community Forum
It is currently Thu Jan 23, 2020 10:43 pm

All times are UTC - 5 hours [ DST ]

Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Panasonic Let'snote J10 (Japan)
PostPosted: Fri Jan 10, 2014 1:05 am 
User avatar

Joined: Wed Jan 08, 2014 12:03 am
Posts: 16
I'm really impressed by Peppermint since it has worked just perfectly on my laptop I got in Japan ;-)

Panasonic Japan: Let'snote J10 Standard (CF-J10RYAHR)

$ inxi -F
System:    Host: [@] Kernel: 3.8.0-35-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Four
Machine:   System: Panasonic product: CF-J10RYAHR version: 002
           Mobo: Panasonic model: CFJ10-2 version: 1 Bios: American Megatrends version: V2.00L10 date: 04/04/2011
CPU:       Dual core Intel Core i3-2310M CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 2100.00 MHz 4: 800.00 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           X.Org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1200@60.0hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 9.1.7
Audio:     Card-1: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
           Card-2: EasyPass driver: USB Audio
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-35-generic
Network:   Card-1: Intel Centrino Advanced-N + WiMAX 6250 [Kilmer Peak] driver: iwlwifi
           IF: wlan0 state: up mac: [@]
           Card-2: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver: r8169
           IF: eth0 state: down mac: [@]
Drives:    HDD Total Size: 250.1GB (2.7% used) 1: id: /dev/sda model: Hitachi_HTS54322 size: 250.1GB
Partition: ID: / size: 35G used: 6.4G (20%) fs: ext4 ID: swap-1 size: 6.35GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 56.2C mobo: 56.2C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 170 Uptime: 8:26 Memory: 899.5/5880.1MB Client: Shell inxi: 1.8.4

[@]: deleted by editor

Internal Devices
- monitor: ok
- HDMI: ok
- VGA: (not tested yet)
- hotkeys: ok
- keyboards (jp-106): ok
- trackpad: ok
- USB 2.0: ok
- USB 3.0: ok [added on Jan 16, 2014]
- SD card slot: ok
- audio output (3.5mm): ok
- audio output (speaker): (doesn't work...under investigation)
- microphone (3.5mm): (not tested yet)
- battery: ok
- power button: (not tested yet)
- lid (e.g. close it to suspend): ok
- WiFi: ok
- eithernet: (not tested yet)

External Hardware
I got all of these in the US.
- Brother DCP-8085DN (printer): ok [added on Jan 16, 2014]
- Brother DCP-8085DN (scanner): (not tested yet)
- Brother DCP-8085DN (ADF): (not tested yet)
- Audioengine D1 (USB DAC): ok
- Logitech Touchpad T650 (USB trackpad): ok
- Logitech RumblePad 2 (game controller): not tested yet
- LG Optimus L9 T-mobile (via USB 2.0, using MTP): ok
- Samsung Nexus 10 1 (via USB 2.0, using MTP): (not tested yet)


But I'll keep it updated as soon as I find any issue.


P.S. A friend of mine who is living in Japan uses Peppermint on his fossil-like desktop:
eMachines (formerly Gateway) J3640
I guess the one he owns is the same as the US model except for Windows on it and the power plug. He said everything had worked fine. Anyway, I'll keep you guys updated about his computer too.

Last edited by culip on Thu Jan 16, 2014 7:56 am, edited 1 time in total.


 Post subject: Re: Panasonic Let'snote J10 (Japan)
PostPosted: Fri Jan 10, 2014 9:35 am 
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Nice :)

Have you tried installing pulseaudio for your sound issues ?
sudo apt-get install pulseaudio pulseaudio-utils pavucontrol

Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
Or here's a direct link to the new forum:

 Post subject: Re: Panasonic Let'snote J10 (Japan)
PostPosted: Wed Jan 15, 2014 5:27 pm 

Joined: Thu Jan 02, 2014 4:07 pm
Posts: 30
Cute little laptop.. but I am a sucker for anything Japanese.
I'm going to have to get my Dreamcast warmed up now..

Is the bios in Japanese?

 Post subject: Re: Panasonic Let'snote J10 (Japan)
PostPosted: Thu Jan 16, 2014 7:44 am 
User avatar

Joined: Wed Jan 08, 2014 12:03 am
Posts: 16
Ted_Elgar wrote:
Cute little laptop..
Yeah, I really like my Japanese laptop "Panasonic Let'snote J10" especially its keyboard ;) The key pitch of my laptop is 17-18mm which is smaller than the the industry standard (19mm).

As you see the picture above there are three extra keys beside the space bar:

US keyboard (us): [pointlessly long space bar (wtf?)]
Japanese (jp106): [Muhenkan] [space bar] [Henkan] [Kana]

And here's my xmodmap
!Swap CapsLock & Control_L
remove Lock = Caps_Lock
remove Control = Control_L
keysym Control_L = Caps_Lock
keysym Caps_Lock = Control_L
add Lock = Caps_Lock
add Control = Control_L

!Muhenkan as Alt_L Meta_L
keycode 102 = Alt_L Meta_L

!Henkan as Escape
keycode 100 = Escape

!Ctrl_R as Composition Key
keycode 105 = Multi_key
that makes the key map

[Muhenkan -> Alt] [space bar] [Henkan -> Esc][Kana]

and allows me to press [Alt] and [Esc] with my thumbs effortlessly. I can't believe that most Vim users press [Esc] with a little finger... I am so lazy that I chose Peppermint :D

Dreamcast (Peppermint: No; Linux: ?; NetBSD: Yes)
Ted_Elgar wrote:
I'm going to have to get my Dreamcast warmed up now..

:o Well, the straightforward answer is that you can't run Peppermint on Dramcast whose CPU is called SuperH SH3el. Peppermint only supports x86 and AMD64 CPUs.[1] But perhaps NetBSD can help.

Windows CE
When I was in Japan I saw Japanese geeks installing Windows CE on their Dreamcast (and I found it hilarious) but it's not realistic to have Windows CE in 2014 for the very reason...

Gentoo team has mentioned their Dramcast support in 2006[2] but I'm not positive if they still work on it.

The latest version of NetBSD (v6.1.2) still supports Dreamcast.[3][4]

Ted_Elgar wrote:
Is the bios in Japanese?

If so, you should send this to Sega ;-)
"How to become a hacker: If you don't have functional English, learn it." by Eric Raymond

Anyway, feel free to ask me when you need to refer to Japanese documents :)


[1] "Download and Install". Peppermint.
[2] Dahlskjaer, C. "Gentoo Linux 2006.1 Unleashed." Gentoo Foundation.
[3] "Platforms Supported by NetBSD". The NetBSD Foundation.
[4] "NetBSD Wiki/ports/ NetBSD/dreamcast". The NetBSD Foundation.

To PCNetSpec:
Thanks for your comment and sorry for delay responding. I'm still investigating my speaker issue and will keep you updated.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours [ DST ]

Who is online

Users browsing this forum: No registered users and 11 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL