Peppermint | Linux OS Community Forum
 
It is currently Thu Sep 20, 2018 4:13 pm

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Lenovo X240
PostPosted: Mon Nov 11, 2013 3:00 pm 
Offline
User avatar

Joined: Wed May 19, 2010 5:10 pm
Posts: 1352
Location: Asheville, NC, USA
I've just received what is probably one of the first few hundred X240 models to arrive in the US. First thing I did was rip out the hard drive and put in a Samsung SSD and install Peppermint Four:

Code:
System:    Host: x240 Kernel: 3.11.0-12-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Four
Machine:   System: LENOVO product: 20ALCTO1WW version: ThinkPad X240
           Mobo: LENOVO model: 20ALCTO1WW Bios: LENOVO version: GIET62WW (2.12 ) date: 09/25/2013
CPU:       Dual core Intel Core i7-4600U CPU (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           X.Org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 9.1.7
Audio:     Card-1: Intel Lynx Point-LP HD Audio Controller driver: snd_hda_intel Sound: ALSA ver: k3.11.0-12-generic
           Card-2: Intel Device 0a0c driver: snd_hda_intel
Network:   Card-1: Intel Ethernet Connection I218-LM driver: e1000e
           IF: eth0 state: down mac: 28:d2:44:35:35:dd
           Card-2: Intel Device 08b2 driver: iwlwifi
           IF: wlan0 state: up speed: N/A duplex: N/A mac: 5c:51:4f:62:f0:b1
Drives:    HDD Total Size: 274.1GB (0.9% used) 1: id: /dev/sda model: Samsung_SSD_840 size: 250.1GB
           2: id: /dev/sdb model: TOSHIBA_THNSNX02 size: 24.0GB
Partition: ID: / size: 222G used: 2.3G (2%) fs: ext4 ID: swap-1 size: 8.28GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 44.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 3018
Info:      Processes: 187 Uptime: 29 min Memory: 733.9/7693.3MB Client: Shell inxi: 1.8.4


By default, WiFi did not work at all. In fact the system would not even recognize that the wireless card was installed. Upon research, the Intel 7260 model cards are only supported in Linux kernel 3.11 and newer (Peppermint Four uses 3.8) so I grabbed the Ubuntu 13.10 kernel and headers and installed them and found some firmware to load and now everything appears to be working like a champ.

Performance wise, this is the fastest booting computer I've ever seen. No it's not the most outrageously spec'ed machine in the world but the boot process is mind-numbingly quick. In other news, the new ThinkPad touchpad is beyond terrible (at least I haven't gotten used to it) so I'll be dusting off the trusty Logitech M505 wireless mouse for a while. Other than that, smooth sailing thus far. :)

_________________
Developer and creator of Peppermint OS.

Google+: gplus.kendallweaver.com
Twitter: @kendalltristan

Peppermint is powered by VPS.NET Cloud Servers.


Top
 Profile  
 
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL