Peppermint | Linux OS Community Forum
 
It is currently Tue Aug 20, 2019 12:17 pm

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 14 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: [SOLVED] Scanner Epson perfection 1670 doesn't work
PostPosted: Tue Nov 26, 2013 4:54 am 
Offline

Joined: Wed Nov 13, 2013 3:29 pm
Posts: 10
Hi everybody.

My scanner, the epson perfection 1670, doesn't work on Peppermint, and even if I installed Xsane it isn't detected.
I tried to follow some Ubuntu's guides on the net, but I did not find any solution.

Before to give up, I decided to ask you if there is a solution..
What should I do?


Last edited by Genesis on Tue Dec 10, 2013 1:03 pm, edited 1 time in total.

Top
 Profile  
 
 

 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Tue Nov 26, 2013 12:54 pm 
Offline
User avatar

Joined: Tue Sep 27, 2011 12:15 am
Posts: 940
Location: Lake Gaston NC
Did you see THIS_ONE?

Also, THIS_THREAD deals with the Epxon xp-305 but you might find it helpful.

_________________
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835
http://peppermintos.com/guide/
viewforum.php?f=5
viewforum.php?f=44


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Thu Nov 28, 2013 7:34 am 
Offline

Joined: Wed Nov 13, 2013 3:29 pm
Posts: 10
I've already followed the first guide, but when I write "scanimage -L" in terminal, this is the output:

Code:
WARNING: gnome-keyring:: couldn't connect to: /run/user/mirko/keyring-Rv0VIq/pkcs11: No such file or directory
device `snapscan:libusb:001:002' is a EPSON EPSON Scanner flatbed scanner


and xsane doesn't detect the scanner ("Impossible to open 'snapscan:libusb:001:002' : there is an I/O errore on the device").

I tried to read the second guide, but I didn't find anything that could help me though


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Thu Nov 28, 2013 9:24 am 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Try the instructions here:
http://www.arakhne.org/epson/

which are to download/install this package:
http://download.tuxfamily.org/arakhne/p ... e1_all.deb
(just download it, double-click it, and hit the "Install Package" button)

Then edit /etc/sane.d/snapscan.conf:
Code:
sudo gedit /etc/sane.d/snapscan.conf

and change the line (line 5):-
Code:
firmware /usr/share/sane/snapscan/your-firmwarefile.bin

to
Code:
firmware /usr/lib/epson-perfection/esfw30.bin

SAVE the file .. then replug your scanner, or reboot

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Sun Dec 01, 2013 4:16 am 
Offline

Joined: Wed Nov 13, 2013 3:29 pm
Posts: 10
Xsane didn't detected again. When I run Xsane, it gives me this error:

Quote:
failed to open device 'snapscan:libusb:001:002':Invalid Argument


I read the snapscan.conf.... Should i edit the string

Quote:
# For USB scanners also specify bus=usb, e.g.
/dev/usb/scanner0 bus=usb


?

if I should, what must I write?

ps.
when i edit /etc/sane.d/snapscan.conf the terminal gives me this message:

Quote:
** (gedit:2292): WARNING **: Could not load theme icon user-bookmarks-symbolic: Icona «user-bookmarks-symbolic» doesn't exist


I don't think this is an important error, but I prefer to show it to you...

pps. when I used a double partition with Ubuntu and Windows, I could use the scanner in Ubuntu only if I previously booted Windows...

Now in my pc I have only Peppermint... If i use Virtualbox to load Windows, is there the possibility that the scanner will be detected also on Peppermint?


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Sun Dec 01, 2013 1:29 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
OK, run:
Code:
scanimage -L

hopefully you'll get some output like

device `snapscan:libusb:001:002' is an EPSON blah blah blah

We're after the bit I've highlighted in red

insert that into a command like this

scanimage -d snapscan:libusb:001:002 > test.pnm

and run it .. are there any clues in the output ?

=======================================================

You're right, the gtk warning is nothing to worry about :)

But if you'd rather not get it in the future, install gnome-icon-theme-symbolic
Code:
sudo apt-get install gnome-icon-theme-symbolic

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Sun Dec 08, 2013 5:58 am 
Offline

Joined: Wed Nov 13, 2013 3:29 pm
Posts: 10
The output of scanimage -L is:
Quote:
WARNING: gnome-keyring:: couldn't connect to: /run/user/mirko/keyring-hTetNH/pkcs11: No such file or directory
device `snapscan:libusb:001:003' is a EPSON EPSON Scanner flatbed scanner

It the first time that i see the WARNING strings with this command

Then I insert scanimage -d snapscan:libusb:001:003 > test.pnm

and this is the output:

Quote:
[snapscan] download_firmware: No firmware entry found in config file snapscan.conf.
scanimage: open of device snapscan:libusb:001:003 failed: Invalid argument


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Tue Dec 10, 2013 11:36 am 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Can you run:
Code:
gedit /etc/sane.d/snapscan.conf

and post its contents on pastebin.com
http://peppermint.pastebin.com
then post a link to your pastebin back here.

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Tue Dec 10, 2013 12:12 pm 
Offline

Joined: Wed Nov 13, 2013 3:29 pm
Posts: 10
Here it is: http://pastebin.com/KNPs3P14


Top
 Profile  
 
 Post subject: Re: Scanner Epson perfection 1670 doesn't work
PostPosted: Tue Dec 10, 2013 12:39 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Try this:-

Run:
Code:
sudo gedit /etc/sane.d/snapscan.conf

When gedit opens, change the line that reads:-

# firmware /usr/lib/epson-perfection/esfw30.bin

to

firmware /usr/lib/epson-perfection/esfw30.bin

SAVE the file .. if necessary unplug/replug the scanner .. then test.

If it still doesn't work, run:
Code:
sudo updatedb

then post the output from
Code:
locate -i esfw30.bin

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL