Peppermint | Linux OS Community Forum
 
It is currently Sun Nov 17, 2019 3:27 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 66 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7  Next
Author Message
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 6:00 pm 
Offline

Joined: Fri Oct 25, 2013 2:01 am
Posts: 33
PCNetSpec wrote:
that GTK warning is nothing to worry about.

OK, can you reboot then before doing anything else, just open a terminal and post the output of
Code:
lsmod

again



sheeb@sheeb-HP-2000-Notebook-PC ~ $ lsmod
Module Size Used by
parport_pc 27504 0
ppdev 12817 0
rfcomm 37420 0
bnep 17669 2
bluetooth 202232 10 bnep,rfcomm
snd_hda_codec_realtek 63791 1
binfmt_misc 17260 1
joydev 17097 0
uvcvideo 71279 0
videobuf2_vmalloc 12920 1 uvcvideo
videobuf2_memops 13042 1 videobuf2_vmalloc
videobuf2_core 39161 1 uvcvideo
videodev 95806 2 uvcvideo,videobuf2_core
coretemp 13131 0
gpio_ich 13236 0
arc4 12543 2
rtl8192ce 52841 0
rtlwifi 69015 1 rtl8192ce
rtl8192c_common 47075 1 rtl8192ce
wmi 18590 0
snd_hda_intel 38307 1
mac80211 526519 3 rtlwifi,rtl8192c_common,rtl8192ce
psmouse 81065 0
serio_raw 13031 0
snd_hda_codec 117617 2 snd_hda_codec_realtek,snd_hda_intel
mac_hid 13037 0
i915 539721 2
snd_hwdep 13272 1 snd_hda_codec
snd_pcm 80890 2 snd_hda_codec,snd_hda_intel
cfg80211 436243 2 mac80211,rtlwifi
video 18894 1 i915
drm_kms_helper 47545 1 i915
snd_page_alloc 14230 2 snd_pcm,snd_hda_intel
snd_seq_midi 13132 0
snd_seq_midi_event 14475 1 snd_seq_midi
snd_rawmidi 25114 1 snd_seq_midi
snd_seq 51280 2 snd_seq_midi_event,snd_seq_midi
drm 228489 3 i915,drm_kms_helper
snd_seq_device 14137 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 24411 2 snd_pcm,snd_seq
snd 56485 11 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device
rtsx_pci_ms 12875 0
lpc_ich 16925 0
memstick 15842 1 rtsx_pci_ms
i2c_algo_bit 13197 1 i915
soundcore 12600 1 snd
microcode 18286 0
lp 13299 0
parport 40753 3 lp,ppdev,parport_pc
rtsx_pci_sdmmc 17238 0
ahci 25507 2
libahci 26108 1 ahci
rtsx_pci 32831 2 rtsx_pci_ms,rtsx_pci_sdmmc
r8169 61543 0
sheeb@sheeb-HP-2000-Notebook-PC ~ $


Top
 Profile  
 
 

 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 6:08 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
OK, that looks a bit better .. but I'm now wondering what happened to hp_wmi

What happens if you load it:
Code:
sudo modprobe hp_wmi

does the wireless switch work then ?

also try:
Code:
sudo modprobe sparse-keymap


You are trying Fn+F12 right ?

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 6:19 pm 
Offline

Joined: Fri Oct 25, 2013 2:01 am
Posts: 33
PCNetSpec wrote:
OK, that looks a bit better .. but I'm now wondering what happened to hp_wmi

What happens if you load it:
Code:
sudo modprobe hp_wmi

does the wireless switch work then ?

also try:
Code:
sudo modprobe sparse-keymap


You are trying Fn+F12 right ?



sheeb@sheeb-HP-2000-Notebook-PC ~ $ sudo modprobe hp_wmi
[sudo] password for sheeb:
sheeb@sheeb-HP-2000-Notebook-PC ~ $ sudo modprobe sparse-keymap
sheeb@sheeb-HP-2000-Notebook-PC ~ $

Toggle key still isn't working. :/


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 6:35 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
OK. all the drivers seem to be loading correctly now

So can you run:
Code:
dmesg > ~/dmesg.txt

you'll then find a file called dmesg.txt in your home folder.

can you email that to me.

I'll PM you my email address.

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 6:48 pm 
Offline

Joined: Fri Oct 25, 2013 2:01 am
Posts: 33
PCNetSpec wrote:
OK. all the drivers seem to be loading correctly now

So can you run:
Code:
dmesg > ~/dmesg.txt

you'll then find a file called dmesg.txt in your home folder.

can you email that to me.

I'll PM you my email address.



I've sent it. :)


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 8:11 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
FYI, it seems to be an ACPI issue ..
Quote:
[ 1210.732657] ACPI Error: Field [B128] at 1152 exceeds Buffer [NULL] size 160 (bits) (20121018/dsopcode-236)
[ 1210.732667] ACPI Error: Method parse/execution failed [\_SB_.WMID.HWCD] (Node f4433c48), AE_AML_BUFFER_LIMIT (20121018/psparse-537)
[ 1210.732679] ACPI Error: Method parse/execution failed [\_SB_.WMID.WMAD] (Node f4440168), AE_AML_BUFFER_LIMIT (20121018/psparse-537)


it looks like hp_wmi is overlapping something else in memory.

Disabling ACPI would probably fix the issue .. but it might cause other issues, like loss of CPU fan control.

Looking for possible solutions now.

Apparently
Code:
sudo modprobe -r hp_wmi

then
Code:
sudo modprobe hp_wmi wireless=1

used to work (and may still in Peppermint 3) .. but they seem to have removed that option from more recent versions of hp_wmi :roll:

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 8:15 pm 
Offline

Joined: Fri Oct 25, 2013 2:01 am
Posts: 33
PCNetSpec wrote:
FYI, it seems to be an ACPI issue ..
Quote:
[ 1210.732657] ACPI Error: Field [B128] at 1152 exceeds Buffer [NULL] size 160 (bits) (20121018/dsopcode-236)
[ 1210.732667] ACPI Error: Method parse/execution failed [\_SB_.WMID.HWCD] (Node f4433c48), AE_AML_BUFFER_LIMIT (20121018/psparse-537)
[ 1210.732679] ACPI Error: Method parse/execution failed [\_SB_.WMID.WMAD] (Node f4440168), AE_AML_BUFFER_LIMIT (20121018/psparse-537)


it looks like hp_wmi is overlapping something else in memory.

Disabling ACPI would probably fix the issue .. but it might cause other issues, like loss of CPU fan control.

Looking for possible solutions now.

Apparently
Code:
sudo modprobe -r hp_wmi

then
Code:
sudo modprobe hp_wmi wireless=1

used to work (and may still in Peppermint 3) .. but they seem to have removed that option from more recent versions of hp_wmi :roll:



yeah, it seems to be not working for me, unfortunately.

sheeb@sheeb-HP-2000-Notebook-PC ~ $ sudo modprobe -r hp_wmi
sheeb@sheeb-HP-2000-Notebook-PC ~ $ sudo modprobe hp_wmi wireless=1
ERROR: could not insert 'hp_wmi': Invalid argument
sheeb@sheeb-HP-2000-Notebook-PC ~ $


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 8:28 pm 
Offline

Joined: Fri Oct 25, 2013 2:01 am
Posts: 33
Went ahead and gave disabling ACPI a try... none of my action keys work any longer, thus making my wifi toggle key (still) not work... went into terminal, rfkill list is still showing I have a hard block... unfortunately sudo rfkill unblock all isn't unblocking my wifi... :/


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 8:31 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
I've just thought of a possible WORKAROUND .....

Apparently the wireless switch USED to work in older kernels (which BTW is what hp_wmi controls)

and someone else said that if he booted to windows and enabled wireless .. then rebooted to Linux the wireless stayed on permanently.

so a possible workaround may be to create a Peppermint Ice LiveCD/LiveUSB .. boot to it .. and enable wireless via the switch.

then wireless should stay ON permanently

As I said, not ideal, and more of a workaround than a fix .. but if you wanna give that a shot whilst I look for a proper fix .. feel free ;)

Peppermint Ice can be downloaded here:
http://peppermintos.info/archive/Pepper ... 110302.iso

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: Trouble installing Realtek 8188CEb/g/n driver on Four
PostPosted: Sat Oct 26, 2013 8:36 pm 
Offline

Joined: Fri Oct 25, 2013 2:01 am
Posts: 33
PCNetSpec wrote:
I've just thought of a possible WORKAROUND .....

Apparently the wireless switch USED to work in older kernels (which BTW is what hp_wmi controls)

and someone else said that if he booted to windows and enabled wireless .. then rebooted to Linux the wireless stayed on permanently.

so a possible workaround may be to create a Peppermint Ice LiveCD/LiveUSB .. boot to it .. and enable wireless via the switch.

then wireless should stay ON permanently

As I said, not ideal, and more of a workaround than a fix .. but if you wanna give that a shot whilst I look for a proper fix .. feel free ;)

Peppermint Ice can be downloaded here:
http://peppermintos.info/archive/Pepper ... 110302.iso



Alright! I'll go ahead and turn ACPI back on, and create the LiveUSB and try that.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 66 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL