Peppermint | Linux OS Community Forum
 
It is currently Wed Aug 15, 2018 3:29 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: revisiting: P4 wifi below 50% [SOLVED 6X]
PostPosted: Mon Jun 24, 2013 10:40 am 
Offline

Joined: Thu Jun 17, 2010 7:46 pm
Posts: 652
Location: somewhere in the Sonoran Desert of Arizona
I like to take my laptop outside and sit in the cool of the morning, but since the wifi connectivity refuses to climb above 50% in this 64 bit installation... I can't connect to anything once i step out the back door... this was not a problem in P3... where wifi connectivity remained above 87% outside...

Code:
spence@hpG6 ~ $ inxi -F
System:    Host: hpG6 Kernel: 3.8.0-25-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Four
Machine:   System: Hewlett-Packard product: HP Pavilion g6 Notebook PC version: 0690130000204610000620100
           Mobo: Hewlett-Packard model: 169B version: KBC Version 18.1A Bios: Hewlett-Packard version: F.46 date: 01/16/2012
CPU:       Dual core AMD A4-3305M APU with Radeon HD Graphics (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 sse4a svm)
           Clock Speeds: 1: 1900.00 MHz 2: 800.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI Sumo [Radeon HD 6480G]
           X.Org: 1.13.3 drivers: ati,radeon (unloaded: fbdev) FAILED: vesa Resolution: 1368x768@0.0hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits) GLX Version: 2.1 Mesa 9.1.3
Audio:     Card-1: Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel
           Card-2: Advanced Micro Devices [AMD] nee ATI BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series] driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-25-generic
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169
           IF: eth0 state: down mac: 78:e3:b5:67:40:5e
           Card-2: Ralink RT5390 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
           IF: wlan0 state: up mac: e4:d5:3d:a7:7f:f2
Drives:    HDD Total Size: 320.1GB (4.8% used) 1: id: /dev/sda model: ST320LM000_HM321 size: 320.1GB
Partition: ID: / size: 15G used: 2.6G (18%) fs: ext4 ID: /boot size: 9.3G used: 75M (1%) fs: ext4
           ID: /home size: 254G used: 12G (5%) fs: ext4
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 58.1C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 144 Uptime: 19 min Memory: 579.6/3429.6MB Client: Shell inxi: 1.8.4


niggly also.... has ctrl+alt+t really ceased to bring up terminal in P4 or is my install borked?


Also [SOLVED] ctrl+alt+t now works again, as does ctrl+alt+delete... imma very happy camper today :D

_________________
spence
'12 HP Pavilion G6-1D26DX ~ peppermintFour 64 bit
'05 Toshiba Qosmio F25-AV205 ~ peppermintFour 32 bit


Do not despair, grasshopper,
with patience all will be revealed,
Through pain, enlightenment will come


Last edited by spence on Mon Feb 03, 2014 10:13 am, edited 6 times in total.

Top
 Profile  
 
 

 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 11:04 am 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
I suppose we could try the STA (staging) drivers if you want ?

Can you try something first though .. run:
Code:
sudo modprobe -r rt2800pci

then
Code:
sudo modprobe rt2800pci nohwcrypt=1

Did that improve anything ?

If so, we'll have to make that automatic at each boot

Also send the output from:
Code:
lspci -vnn | grep -i net

and
Code:
sudo lshw -C display

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 11:09 am 
Offline

Joined: Thu Jun 17, 2010 7:46 pm
Posts: 652
Location: somewhere in the Sonoran Desert of Arizona
boosted to 61%, still not good enough to hold a signal out the back door thru our solid brick walls...

Code:
spence@hpG6 ~ $ sudo modprobe -r rt2800pci
[sudo] password for spence:
spence@hpG6 ~ $ sudo modprobe rt2800pci nohwcrypt=1
spence@hpG6 ~ $ lspci -vnn | grep -i net
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
07:00.0 Network controller [0280]: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe [1814:5390]
spence@hpG6 ~ $ sudo lshw -C display
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: Sumo [Radeon HD 6480G]
       vendor: Advanced Micro Devices [AMD] nee ATI
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:e0000000-efffffff ioport:4000(size=256) memory:f0500000-f053ffff

_________________
spence
'12 HP Pavilion G6-1D26DX ~ peppermintFour 64 bit
'05 Toshiba Qosmio F25-AV205 ~ peppermintFour 32 bit


Do not despair, grasshopper,
with patience all will be revealed,
Through pain, enlightenment will come


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 11:25 am 
Offline

Joined: Thu Jun 17, 2010 7:46 pm
Posts: 652
Location: somewhere in the Sonoran Desert of Arizona
PCNetSpec wrote:
I suppose we could try the STA (staging) drivers if you want ?


ummmm yikes... http://www.cs.fsu.edu/~baker/devices/lxr/http/source/linux/drivers/staging/rt2860/sta_ioctl.c

_________________
spence
'12 HP Pavilion G6-1D26DX ~ peppermintFour 64 bit
'05 Toshiba Qosmio F25-AV205 ~ peppermintFour 32 bit


Do not despair, grasshopper,
with patience all will be revealed,
Through pain, enlightenment will come


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 12:36 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
OK, wireless first (then we need to have a looksee at your graphics drivers)

run these commands in sequence:
Code:
mkdir ~/RT5390STA

then
Code:
cd ~/RT5390STA

then
Code:
wget "https://dl.dropboxusercontent.com/u/11876059/2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO(kernel_3.8).tar.gz"

(the above is all one command, so copy/paste it)
then
Code:
tar -xvf "2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO(kernel_3.8).tar.gz"

then
Code:
cd ~/RT5390STA/2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO

then
Code:
sudo su

then
Code:
make

then
Code:
make install

then
Code:
exit

then
Code:
sudo modprobe -r rt2800pci

then
Code:
sudo modprobe rt5390sta


Is wireless any better now ?

Can you post the output from:
Code:
sudo lshw -C network

then reboot and post the output (if any) from:
Code:
lsmod | grep rt

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 1:18 pm 
Offline

Joined: Thu Jun 17, 2010 7:46 pm
Posts: 652
Location: somewhere in the Sonoran Desert of Arizona
wifi connection is now 100% ... inside.... and ... ... ... still 100% outside...
Code:
spence@hpG6 ~ $ sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 05
       serial: 78:e3:b5:67:40:5e
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:43 ioport:3000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
  *-network
       description: Wireless interface
       product: RT5390 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: ra0
       version: 00
       serial: e4:d5:3d:a7:7f:f2
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=RALINK WLAN ip=192.168.1.8 latency=0 multicast=yes wireless=Ralink STA
       resources: irq:17 memory:f0300000-f030ffff


and will edit here after reboot...

:? wifi back to 51% outside... 55% inside after reboot...

Code:
spence@hpG6 ~ $ lsmod | grep rt
parport_pc             28152  0
rt5390sta            1460542  0
rt2800pci              18582  0
rt2800lib              66507  1 rt2800pci
rtsx_pci_ms            13011  0
rt2x00pci              14519  1 rt2800pci
rt2x00lib              54869  3 rt2x00pci,rt2800lib,rt2800pci
memstick               16554  1 rtsx_pci_ms
mac80211              606457  3 rt2x00lib,rt2x00pci,rt2800lib
cfg80211              510937  2 mac80211,rt2x00lib
eeprom_93cx6           13344  1 rt2800pci
crc_ccitt              12707  1 rt2800lib
parport                46345  3 lp,ppdev,parport_pc
rtsx_pci_sdmmc         17475  0
rtsx_pci               33355  2 rtsx_pci_ms,rtsx_pci_sdmmc

_________________
spence
'12 HP Pavilion G6-1D26DX ~ peppermintFour 64 bit
'05 Toshiba Qosmio F25-AV205 ~ peppermintFour 32 bit


Do not despair, grasshopper,
with patience all will be revealed,
Through pain, enlightenment will come


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 1:28 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Can you post the output from:
Code:
sudo lshw -C network

again

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 1:40 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
Run:
Code:
sudo gedit /etc/modprobe.d/blacklist.conf

add these 5 NEW LINES at the very bottom:-

Code:
# Added by spence - blacklist conflicting wireless modules
blacklist rt2800pci
blacklist rt2800lib
blacklist rt2x00pci
blacklist rt2x00lib


SAVE the file, and REBOOT.

is wireless back to 100% ?

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 1:48 pm 
Offline

Joined: Thu Jun 17, 2010 7:46 pm
Posts: 652
Location: somewhere in the Sonoran Desert of Arizona
Code:
spence@hpG6 ~ $ sudo lshw -C network
[sudo] password for spence:
  *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 05
       serial: 78:e3:b5:67:40:5e
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:41 ioport:3000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
  *-network
       description: Wireless interface
       product: RT5390 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: wlan0
       version: 00
       serial: e4:d5:3d:a7:7f:f2
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=3.8.0-25-generic firmware=0.34 ip=192.168.1.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f0300000-f030ffff


before i reboot, what is this error message i keep getting from the terminal about lately?

Code:
spence@hpG6 ~ $ sudo gedit /etc/modprobe.d/blacklist.conf

** (gedit:16119): WARNING **: Could not load theme icon user-bookmarks-symbolic: Icon 'user-bookmarks-symbolic' not present in theme
spence@hpG6 ~ $

_________________
spence
'12 HP Pavilion G6-1D26DX ~ peppermintFour 64 bit
'05 Toshiba Qosmio F25-AV205 ~ peppermintFour 32 bit


Do not despair, grasshopper,
with patience all will be revealed,
Through pain, enlightenment will come


Top
 Profile  
 
 Post subject: Re: P4 wifi stays below 50%
PostPosted: Mon Jun 24, 2013 1:55 pm 
Offline
User avatar

Joined: Tue Apr 17, 2012 12:25 pm
Posts: 5521
Location: Cornwall, England
spence wrote:
before i reboot, what is this error message i keep getting from the terminal about lately?

Code:
spence@hpG6 ~ $ sudo gedit /etc/modprobe.d/blacklist.conf

** (gedit:16119): WARNING **: Could not load theme icon user-bookmarks-symbolic: Icon 'user-bookmarks-symbolic' not present in theme
spence@hpG6 ~ $


Nothing to worry about .. but if you "really" want rid of it .. install gnome-icon-theme-symbolic
Code:
sudo apt-get install gnome-icon-theme-symbolic

_________________
Please be sure to sign up to the new Peppermint forum and post any new question there .. this forum will be made read-only on the 1st April 2014

You can read the announcement here:
http://peppermintos.net/viewtopic.php?f=6&t=6608
Or here's a direct link to the new forum:
http://forum.peppermintos.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2, 3  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

Powered by php B.B. © 2000, 2002, 2005, 2007 php B.B. Group
Template made by DEVPPL